PNP
PSPとかNDSとかポータブル。このブログの記事を参考にされてPSPやその他、機器に不具合が起きても責任は負えませんので、自己責任にてお願いします。
スポンサーサイト
--年--月--日 (--) --:-- | 編集
上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。
[PSP] Devhook
2006年12月13日 (水) 10:12 | 編集
BBSへのTamさんの投稿を記事にさせていただきます!
Tamさんありがとうございます!
改行等の修正を少しだけ入れてます。文自体はそのままです。

------------以下Tamさん投稿記事---------------
こっそり書いてみました

長らくテストしていたモンハンですが、
「DevHook v0.51 Launcher for 2.71 HEN-D」で起動できました。もちろんTA-082です。
このDevhookはHEN Dのみで起動なのでHEN B/CであればHEN Dをインストールして下さい。昔のDevhookも起動します。またDevHook v0.51 Launcher for 2.71 HEN-Dは仮想FW1.50は対応してませんが、モンハンが起動したのは仮想3.01でした。

Devhookは簡単なのですが、仮想FW3.01を起動させるためのFW3.01ダンプが難しかったです。FW2.81以上はどうやら各々のPSPで仮想FWファイルを作る必要があるようです。

①まずは必要ファイルをダウンロードして下さい。
DevHook v0.51 Launcher for 2.71 HEN-Dをダウンロード
http://www.psp-hacks.com/file/936

3.01 Update EBOOT(英語でも問題なく動きました。○×も日本のキーで起動しました)
http://www.psp-hacks.com/file/934

PBP Unpacker(EBOOT.PBPをDATA.PSARへ変換)
http://www.psp-hacks.com/file/97

Modified PSAR Dumper(DATA.PSARをDevhook用のファイルへ変換。f0フォルダが作成される)
http://www.psp-hacks.com/file/918

②以前から動いているDevhookがあるMSを用意します。私は念のためms:0/dhフォルダを適当な名前に変えて保存 ex) ms:0/dh_old。今度は

DevHook v0.51 Launcher for 2.71 HEN-Dを解凍しMS_ROOT\dhフォルダの中身をms0:/dhへコピー。そして昔のms:0/dh_oldフォルダにある150と271を新しいmd0:/dhへコピー。次にMS_ROOT\PSP\GAME\DH51_271をms0:/PSP/GAMEへコピー。

③3.01 Update EBOOTを解凍。PBP Unpackerをインストールし起動。PBP Unpacker起動後、「Open」を押し、解凍した3.01 Update EBOOTにあるEBOOT.PBPを選んでください。するとDATA.PSARができますので、このDATA.PSARをMSのルートへコピー。

④Modified PSAR Dumperを解凍したら、psar_dump2とpsar_dump2%をms0:/PSP/GAMEへコピーします。

⑤PSPで今度は、HEND→以前のDevhookでFW1.50を起動→PSAR Dumperを起動。×を押します。確か黒い画面です。終わると再起動されますが、MSのルートにはF0ができてます。これが仮想FW3.01を起動するために必要なファイルです。このF0をms0:/dh/301/f0へ上書きコピーします。

DATA.PSARはもう不要です。

⑥今度はHEND→新しいであるDevHook v0.51 Launcher for 2.71を起動。"flash install"→"install configfile to flash1"。ここちょっと怖かったですが、問題なかったです。F0からF1を作成してくれる肯定です。これが終わったら、Devhook画面のRun Devhook。あたかも新しいFWになったような初期画面がでますが、これは仮想FW3.01ですのでご安心を

⑦PSPを再起動し、HEND→新しいDevHook v0.51 Launcher for 2.71を起動します。

⑦スピードを333、ファイルの起動を特定のISOへ、確かブートをAuto UMDのようなものにしたと思います。
これでモンハンは動きました。

※まだまだWiFiテストやバグなどはチェックしてないですが、起動したのはありたがったです。
分かりにくい文ですみませんが、トライしてみて下さい。
--------------ここまで--------------------

私もTamさんの記事を参考に3.01の導入に成功してます!

06/12/13
2.80-3.02 DevHook Firmware Installer 0.5b
3.02 DH Firmware Installer
Devhook 0.51.0100 released
New menus for Devhook v0.51 with FW 3.02 support
Install firmware 3.02 to DevHook with ease
PSP Firmware 3.02 out - Works in Devhook too!
Don't pull your hair out - use the 3.01 DevHook Firmware Installer
Dark_AleX's Devhook 0.51 launcher port for 2.71 HEN-D and TA-082

さてさてさて、Devhookもバージョンが0.51になり、FWも3.02までサポート(正式ではない?)されていい感じになってきましたね!
TA-082なPSPでも問題なく3.01の起動に成功できました。
また、記事は書きますが、BBSにてTamさんのTA-082なPSPでの導入手順がかいてありますので、参考にさせていただきましょう!
Tamさんありがとうございました!

06/12/05
Devhook 0.51 released - 3.01 PSP Firmware emulation!

3.01対応のDevhook0.51がリリースされましたね!
どんどん進化してます。
開発お疲れ様です!



06/12/04
DevHook alternative package updated: DevHook 0.50, 0.46, DevHook for 2.71, and 0.45

DevHook 0.50 AND older DevHooks on your PSP

Emulation heaven: Booster's back with DevHook v0.50 - fw2.8x emulation!

さて、いまさら感たっぷりな上にまだ試せてなくて申し訳ないのですが、Devhook0.50が公開されましたね。
FW2.82の起動ができるとか。
試してみたいですねぇ。
ダウンロードしてファイルを解凍してみたら、dhフォルダの中に301フォルダがありますね。
FW3.01の起動にものちのち対応するっぽい!?

06/11/07
続きに追加情報を追記しました。

06/11/02
現状Devhookでは2.71までの仮想化しかできませんが、ちょっと試しにDevhook0.47、でGoogleで検索をかけてみると海外で結構記事が見つかります。ダウンロード先なんかもあったりします。が、記事をよく見てみるとウィルスであると。
英語だと日本語のようにニュアンスがわかんないからウィルスだよと、書いてなかったらダウンロードしいてしまいそうやね;
気をつけましょう。

06/10/21
と、いうことでTA-082基板、FW2.71なPSPでDevhookを起動をやってみました。

追記:06/10/21
FW1.5のUS版をゲットできましたので、仮想FW1.5の起動もやってみました。

06/09/28
Dark Alex氏のサイト
なんか偽者だかなんだかでちょっとあるみたいですね。
サイトのトップに書かれてます。
プログラムの開発は続けて欲しいところです。

で、homebrew enablerを使用してDevhookを起動し、仮想FW1.5を起動しようという作戦は結論から言うと、できるみたいです。
みたいですといったのはまだ試せてないってことですが。。。
ただ、TA-082基盤でFW2.71なPSPしか持っていない人には厳しいツールになってるように思われるのですが。
FW1.5でDevhookをばんばん使ってた人なんかは簡単にできそうなことですが、eloaderに頼ってた人たちにとってはなかなか難しいかもしれませんね。しかも、1.5のない人はおそらくdevhook用にFWのファイルの展開なんてこともできないと思われるのですがどうなんでしょう。
仮想2.71くらいは起動できるんやろか。

試してから書けっちゅーはなしやね;

06/09/27
Homebrew Enabler for fw2.71 now ported to DevHook
Devhook launcher port updated: 2.71 Flash support
Stop ripping off the scene PS2NFO!

Dark Alex氏の偽者・・・?
Homebrew Enabler for 2.71 (Revision B) Starts PSP Utopia
Devhook Launcher Port for 2.71

ちょっと関連記事を探してたらなんかいっぱい・・・
時間がほしいよ~。
ちょっと試してみたんだけど、とりあえず2.71でDevhookの起動までは確認できました。そこからFW1.5の立ち上げが確認できてません。
時間のある時にもう少しやってみます・・・

------------------------------------------------------------
とりあえずできたこと。
FW2.71上でHENC起動後、Devhook for 2.71を起動し、仮想FW2.71の起動。

DevHook v0.46 Ultimate Installer v1.1.1
Dark_AleX氏のサイト

準備する物。
TA-082,FW2.71基板PSP。
MSDuo(容量は適当に大目の物がよさそげ)
Homebrew enabler for 2.71 (Revision C)
DevHook v0.46 Ultimate Installer v1.1.1
Devhook launcher port to 2.71 (now with support of 2.71 flash)

手順。
1.上記2種のファイルをダウンロードする
2.Ultimate Installerを起動する。
3.適当にインストールしたいものを選択する(今回はWITH 2.71を選択)
4.日本語化ファイルをデスクトップ上に保存し、MSDuoの該当するフォルダに上書きする。
5.devlauncher271_2.rarを解凍し、中のDH_ENG271フォルダをMSDuo内のGAMEフォルダにぶちこむ
6.HENCを起動する
7.XMBからDEVHOOK0.4X launcher for 2.71を起動する
8.Devhookが立ち上がるので起動したいFWを選択して起動する(今回は2.71を選択)
9.PSPが再起動後仮想FW2.71が起動する

今回のインストールで仮想2.71がたちあがったっぽいです。
壁紙がUltimate Installerの初期設定になっているっぽいので変化がわかると思われます。
ブラウザ等を起動するとMSにアクセスを頻繁に行いますので、間違いなく仮想FW2.71が起動しています。
ただ、仮想2.71が起動できてもUMDからISOファイルの作成や、仮想1.5の起動などまだまだやることが盛りだくさんってところっすね。

追記:仮想FW1.5の起動

やった手順。
1.FW1.5のUS版のデータをダウンロード
2.がんばれ!PSP&ちょっとだけDSさんのサイトを参考にdh/150/flash0/vsh/module/vshmain.prxのファイルをCustom Firmware - The Proof of Conceptからコピーします。もともとあったvshmain.prxはvshmain_real.prxにリネームする
3.dh/271/flash1/registry/フォルダ内のsystem.dregとsystem.iregをdh/150/flash1/registry/フォルダにコピーする
4.PSPを起動し、Devhook0.4X launcher for 2.71を起動する
5.FW1.5を選択し、起動する

ということで、仮想FW1.5の起動に成功しました。
US版のFWを入れてそのままだとだめで他のサイトさんも参考にさせていただきました。
がんばれ!PSP&ちょっとだけDSさん、PSP徹底活用さんありがとうございました。
これでいろいろと自作ソフトウェアの起動も広がりいろいろと楽しめそうです。

追記:
ノーマル2.71からHENC起動、Devhook for 2.71にて1.5を起動後、仮想2.71を起動するには、Devhook for 2.71では起動できませんので、FW1.5用のオリジナルのDevhook0.45、0.46かMOD系のDevhookを入れてそれを起動すると仮想2.71にすることができます。

仮想2.71から仮想1.5に戻す方法もあるようですが、勉強中っす。
スポンサーサイト
コメント
この記事へのコメント
参考にさせていただき成功しました。ありがとうございます。ただ仮想1.5からDevhookを再度起動させて仮想2.71に,戻ろうと思ったら起動エラーになります。強制リセットしかないんでしょうか?
2006/11/03(金) 01:40:32 | URL | YoneKing #-[編集]
YoneKingさん
そこの説明がなかったですね。
ノーマル2.71からDEVHOOK0.4X launcher for 2.71で1.5を起動すると、仮想1.5上だとDEVHOOK0.4X launcher for 2.71は使えなかったと思います。
そこで、FW1.5用のDevhookを入れてそこから起動すると仮想2.71を起動できます。
が、仮想2.71から1.5への起動はまだ試してません。

1.5用のDevhookはノーマルなDevhook0.45か0.46あたりを使うか、その他MOD系を使われても起動できると思われます。
2006/11/03(金) 22:51:07 | URL | sds #y0EsocJs[編集]
助言ありがとうございました。FW1.5用Devhook046をインストールして試してみました。仮想1.5から仮想2.71は見事に成功しました!その仮想2.71から仮想1.5に戻るべくDEVHOOK0.4X launcher for 2.71を起動するもエラー・・・試しにDevhook046も試すも仮想2.71に戻ってしまいました。まあ,仮想1.5と仮想2.71を自在に行き来は出来ませんでしたが満足できました。他のサイトではイマイチ設定できませんでしたが,ここの解説は最高です。これからも活用させていただきたいと思いますので,よろしくお願いいたします。
2006/11/05(日) 03:47:51 | URL | YoneKing #-[編集]
こんばんわ。以前一度コメントさせていただいたものです。
同じTA-082基盤PSPなので、大変参考にさせていただいております。
私はやっとHENCの起動が安定し、Devhook launcher port to 2.71 も起動するのですがそっからがまったくうまくいかず悩んでおります。。。Devhook launcher で2.71や、1.5を選択しスタートすると真っ暗になり電源が落ちます・・・「PSP徹底活用」様のところでもいろいろ調べてみたのですが、どちらでも無理なようです(;´Д`)
またeloaderで遊んでいた方が私にはあってるのかも・・・と弱気になってます( TДT)
もし、なにか助言がありましたらよろしくお願いいたします。
2006/11/05(日) 06:31:14 | URL | mimi #-[編集]
82をメインに扱ってるところは中々ありませんね。
こちらの管理人さまに感謝。

参考になるか分かりませんが・・・

1:DEVHOOK0.4X launcher for 2.71のdhに1.50を展開
2:MODのファイルをそれに上書きでMODを使用する

MODは1.50と2.71上で起動できるためlauncherメニューでFW2.71を選択時にHENCを有効に設定することで、2.71をエミュレートしているときにXMBからDEV起動が可能になります。

結果、素2.71⇒1.50⇔2.71となります。

Zanの現状ですが、上記の通りには成功してるのですがなぜかモンハンだけは起動に失敗します・・・

MODも2.71Fに対応してるのですが2.71⇒2.71Fで試したところ設定破損が表示され初期設定の画面に。
1.50⇒2.71Fもブラックアウトとなります。

エミュレートできていればFは使用しなくても良いかと思いますが、使用するときはFのみとなるかと。

今はなんとか2.71エミュでモンハンが起動できないかと思考中です。

それではまた、ふらっと立ち寄ります。



2006/11/06(月) 00:37:21 | URL | Zan #-[編集]
やりました!
2.71起動しました!!!
こちらのサイトのおかげです!!
勉強不足だった自分もありますが・・・(;・∀・)

また参考にさせてください☆
2006/11/06(月) 06:27:15 | URL | mimi #-[編集]
>YoneKingさん
起動できたようで、良かったです。
多分画像とかあんまり使わないサイトなんでわかりづらいかもしれませんが、のらりくらりと更新していきますので、これからもよろしくお願いします。
1.5から戻る方法はZanさんの回答であるとおりにすればできそうな気がします。
私も2.71>1.5>2.71は試しましたが、そこから1.5は試してませんので一度試してみます。

>mimiさん
私のその現象は一度なったような記憶があります。
reboot.binの入れ忘れか、メモリースティックの再フォーマット、又はdhフォルダの入れなおし等でなおるかもしれませんので一度試してみるといいかも。
・・・・・
と、思ったら2.71起動できたんですね。
良かったです。

>Zanさん
ご回答ありがとうございます。
082情報がいっぱい集まればと思いますので、これからもよろしくお願いします。
おっしゃられてるMODっていうのはHENCが有効な状態の2.71を起動できる物なんでしょうか。
勉強不足か、今までまだ見たことないっす・・・
探してみます!
情報ありがとうございました。
モンハンの起動というのはUMDでしょうか、ISOでしょうか。
とりあえずUMDでの起動は確認できましたが。
ISOにはまだしてないので、また試してみます。。
2006/11/07(火) 00:31:42 | URL | sds #y0EsocJs[編集]
>sdsさん
082ユーザーの為にもそれをメインとするサイトが必要と感じますので自分の知る範囲のことは残せればと思っています。

通常はDEVHOOK0.4X launcher for 2.71を使用し仮想1.50から仮想2.71を起動した場合、仮想2.71上でDEV起動ができませんよね。
それはHENCを使用していない素2.71上で起動しようとしてることと同じなのでは。と自分は解釈しています。
MODはメニューからADD-ON MENUを選択するとHEN(2.71only)の項目がありますのでそれを有効に設定することで仮想2.71からDEV起動ができるようになります。
その機能を利用すれば再び仮想1.50の選択ができます。
素1.50&素2.71(082も含む)とも起動可能なものなので別に1.50で起動可能なDEVを入れなくても1つのlauncherで済みます。

モンハンについて
1.50のPSPでMODをそのまま使用すると仮想2.71で問題なくisoが起動するのですが、082の2.71PSPで上書き後のMODを使用するとicon&BGは表示されるものの起動しようとすると失敗します。
自分の所有するものではモンハンのみ失敗でしたが、もしかしたら他にもあるかもしれません。
原因は上書きにあると思うのですが、上書きをしないと1.50が起動できません。上書き無しでファームを展開して試しましたがブラックアウトでした。
上書きをしないで仮想1.50が起動できるようになれば何も問題ないのですが・・・
中身はZanの頭では到底ムリっす。。。

2.71Fしか使わない!って人には機能も豊富なので使用してみてはいかがでしょうか。
2006/11/08(水) 00:58:41 | URL | Zan #-[編集]
いつも参考にさせてもらっています。
今、GジェネPをCWCheatで改造しようとしているのですが、FW2.71から仮想FW1.50は起動できたのですが、仮想FW1.50から仮想FW2.71を起動すると画面が真っ暗になり、しばらくすると電源が切れてしまいます。どうすればよいのでしょうか。
MODとdevhook(DEVHOOK0.4X launcher for 2.71とdevhook 0.46)両方試してみましたがともに上で書いたような状態になりました。
2006/11/09(木) 07:00:10 | URL | mu #OQrRbpXc[編集]
>Zanさん
アドバイスありがとうございます!
結果、Original2.71HENC>Dev1.5<>Dev2.71HENCとLauncher一つで可能となりました。
時間が取れたらこれもまとめてみたいと思いますが、現状のまとめ方にもう少し改善しいたらいい点とかありましたら、アドバイスいただければ嬉しいです。
MODを使用したことによってスクリーンキャプチャも可能になったので、画像ももう少し入れていければと思います。

モンハンも時間が取れたらISO化してためしてみようと思います。

>muさん
Original2.71>Dev1.5が可能なようですが、Original2.71>Dev2.71は可能なんでしょうか?
Devhookの導入手順、症状などをもう少し詳しく書いていただけるとわかるかもしれませんが。
2006/11/09(木) 13:31:58 | URL | sds #y0EsocJs[編集]
>sdsさん
captuerもSVcapもあるので画像やgif動画を取り入れるのには重宝するのでは!
これからの方には画像入りの方が分かり易いのかと思いますが自分的には現状でも分かり易いのでsdsさんの視点で良いのではと思います。

>muさん
自分は改造しないのでアレなんですがCW Cheatなどの機能もModにありますね。
271の展開はDevHook v0.46 Ultimate Installer v1.1.1の記事を参考にもう1度トライしてみては。
2006/11/09(木) 22:18:23 | URL | Zan #-[編集]
>sdsさん
>Zanさん
アドバイスありがとうございます
Original2.71→Dev2.71を試したところ、同じ症状が出たので、もう一度DevHook v0.46 Ultimate Installer v1.1.1をやり直してみたらうまくいきました。
2006/11/11(土) 03:23:01 | URL | mu #-[編集]
>Zanさん
ご報告が遅れて申し訳ないのですが、Zanさんのアドバイスを参考に新しく記事を書きました。
ありがとうございました!!
これからの記事も今まで通りでしばらくはいこうかと思います。
ご意見ありがとうございます!

>muさん
うまくいったようでよかったです^-^
2006/11/12(日) 22:05:32 | URL | sds #-[編集]
>sdsさん
TA-082を扱っているサイトが少ないので非常に参考になります。これからも宜しくお願いします。

>Zanさん
sdsさんにも同様なのですが、自分もモンハンを色々試しているのですが、FW1.5の方々が使っている
UMDEmulator&RunUMDを使ってみてもうまく始動しませんでした。。。試し方が悪いのかもしれませんが、
また進展ありましたら連絡します。
2006/12/05(火) 06:56:08 | URL | Tam #-[編集]
>Tamさん
いらっしゃいませ。
まったりゆったりペースで更新していく予定ですが、よろしくお願いします。
モンハンのことですが、ここの記事以外の他の記事やBBSでも書かれていますので読んでみてくださいな。
2006/12/05(火) 23:17:24 | URL | sds #y0EsocJs[編集]
>Tamさん
同志が増えることは様々な情報に比例するので歓迎です。
自分はDEVHOOKonlyなもので他は試してないです。
”旨み”=HEND+DH150⇔DH271
が今の課題ですかね・・・
MHPを除けば目的が果たせているのですが自分的に何かスッキリしない現状。
”旨み”を切り離せばMHPも解決するのですが・・・

DEV051などで何かとイジイジしてた為、今まで停止中でしたがそろそろコッチもイジイジしようかと思っています。

>sdsさん
お疲れ様です!
DH271(282)は当然HEN機能は不可ですね。
他FWリブートは出来なくなりますが282まではOKだと思います。282以上は試せてません。
UMDは271以上の物を持ってないので試せないでいますが・・・
やっぱり電源OFFは避けられないものなのか。。。
モンハンで頭がパーン!で150なPSPをイジイジでした。
しかしv302起動スゴイですね!BOOSTER氏がいなければ全てが止まりますな。
Dax氏もとても心配ですし・・・
TA82にも繁栄されることを祈るばかりです。
2006/12/07(木) 02:39:28 | URL | Zan #-[編集]
初めまして
TA-082基板、Fw2.71を使用しているので管理人様が書かれた記事通りに
HENCを適用し、Devhook v0.46を導入してみたのですが
Devhookの起動はできてもFw1.5に仮想できません。
そもそもDevHook v0.46 Ultimate Installer v1.1.1
で作成したフォルダdhの中に150がありません。
自作アプリの使用には完全初心者なので、なにとぞご教授頂けないでしょうか?
2006/12/09(土) 03:48:55 | URL | ソゼ #-[編集]
>Zanさん
BBSのTamさんの投稿を参考にとりあえず3.01の起動を私のTA-082で確認できました。
モンハンの起動もできるようですが、まだ確認はとれてません。
Booster氏とDax氏には本当に感謝です。
3.02の起動もやってみまーす。

>ソゼさん
いらっしゃいませ。
仮想2.71を起動する手順の下に仮想1.5の起動手順が書かれていますので参考にしてみてくださいな。
2006/12/11(月) 23:03:43 | URL | sds #y0EsocJs[編集]
起動はするのですが通信対戦ができません。どうすればいいですか?
2006/12/23(土) 23:15:36 | URL | ryo #-[編集]
>ryoさん
私はwifi等の通信を使用してゲーム等を行ったことがないため詳細がわかりません。
ただ、他の有名サイトさん等では話題にのぼっていることが多いと思いますので一度ご覧になってはいかがでしょうか。
有効な情報でなく申し訳ない;
2006/12/25(月) 18:26:20 | URL | sds #y0EsocJs[編集]
コメントを投稿する
URL :
コメント :
パスワード :
秘密 : 管理者にだけ表示を許可する
 
トラックバック
この記事のトラックバックURL
この記事へのトラックバック
copyright&template: himeco
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。